JBoss Jakarta EE 8 Web Profile APIs


License

License

Categories

Categories

JBoss Container Application Servers
GroupId

GroupId

org.jboss.spec
ArtifactId

ArtifactId

jboss-jakartaee-web-8.0
Last Version

Last Version

1.0.0.Final
Release Date

Release Date

Type

Type

pom
Description

Description

JBoss Jakarta EE 8 Web Profile APIs
JBoss Jakarta EE 8 Web Profile APIs
Project Organization

Project Organization

JBoss by Red Hat
Source Code Management

Source Code Management

https://github.com/jboss/jboss-jakartaee-specs

Download jboss-jakartaee-web-8.0

How to add to project

<!-- https://jarcasting.com/artifacts/org.jboss.spec/jboss-jakartaee-web-8.0/ -->
<dependency>
    <groupId>org.jboss.spec</groupId>
    <artifactId>jboss-jakartaee-web-8.0</artifactId>
    <version>1.0.0.Final</version>
    <type>pom</type>
</dependency>
// https://jarcasting.com/artifacts/org.jboss.spec/jboss-jakartaee-web-8.0/
implementation 'org.jboss.spec:jboss-jakartaee-web-8.0:1.0.0.Final'
// https://jarcasting.com/artifacts/org.jboss.spec/jboss-jakartaee-web-8.0/
implementation ("org.jboss.spec:jboss-jakartaee-web-8.0:1.0.0.Final")
'org.jboss.spec:jboss-jakartaee-web-8.0:pom:1.0.0.Final'
<dependency org="org.jboss.spec" name="jboss-jakartaee-web-8.0" rev="1.0.0.Final">
  <artifact name="jboss-jakartaee-web-8.0" type="pom" />
</dependency>
@Grapes(
@Grab(group='org.jboss.spec', module='jboss-jakartaee-web-8.0', version='1.0.0.Final')
)
libraryDependencies += "org.jboss.spec" % "jboss-jakartaee-web-8.0" % "1.0.0.Final"
[org.jboss.spec/jboss-jakartaee-web-8.0 "1.0.0.Final"]

Dependencies

compile (21)

Group / Artifact Type Version
jakarta.enterprise : jakarta.enterprise.cdi-api jar
jakarta.inject : jakarta.inject-api jar
jakarta.json : jakarta.json-api jar
jakarta.json.bind : jakarta.json.bind-api jar
jakarta.persistence : jakarta.persistence-api jar
jakarta.security.enterprise : jakarta.security.enterprise-api jar
jakarta.validation : jakarta.validation-api jar
org.jboss.spec.javax.annotation : jboss-annotations-api_1.3_spec jar
org.jboss.spec.javax.ejb : jboss-ejb-api_3.2_spec jar
org.jboss.spec.javax.el : jboss-el-api_3.0_spec jar
org.jboss.spec.javax.faces : jboss-jsf-api_2.3_spec jar
org.jboss.spec.javax.interceptor : jboss-interceptors-api_1.2_spec jar
org.jboss.spec.javax.resource : jboss-connector-api_1.7_spec jar
org.jboss.spec.javax.servlet : jboss-servlet-api_4.0_spec jar
org.jboss.spec.javax.servlet.jsp : jboss-jsp-api_2.3_spec jar
org.apache.taglibs : taglibs-standard-spec jar
org.apache.taglibs : taglibs-standard-impl jar
org.jboss.spec.javax.transaction : jboss-transaction-api_1.3_spec jar
org.jboss.spec.javax.websocket : jboss-websocket-api_1.1_spec jar
org.jboss.spec.javax.ws.rs : jboss-jaxrs-api_2.1_spec jar
org.jboss.spec.javax.xml.bind : jboss-jaxb-api_2.3_spec jar

Project Modules

There are no modules declared in this project.

JBoss Jakarta EE Specs API

This project provides dependency management for a complete set of required APIs as defined by the Jakarta EE Platform Specifications.

This project goals:

  • Maintain a single repository containing the required APIs as defined by the Jakarta EE Platform Specification
  • Having a consistent structure for all the Jakarta EE APIs make it easier to access, maintain, and consume.
  • Individual release cycle per technology component
  • Each API set can be released individually provides greater flexibility and control to the project owners without waiting for the aggregate to be released and integrated. These API releases can be consumed by your project as a single dependency or as a fully defined set of required APIs for the profile.
  • Define a naming scheme to associate the Specification version to the APIs contained in the JAR and distinguish between that and the release version of the artifact
  • The naming scheme adopted is as follows:
    • groupId: org.jboss.spec + the package name
    • artifactId: Technology-api_SpecVersion_spec
    • version: release version of the artifact
  • Promote adoption of these spec-versioned APIs in all JBoss projects
  • The APIs released from the org.jboss.specs project are certified for compliance to their respective specification.

Jakarta EE Full Profile APIs

If you require the full set of required technology APIs defined by the Jakarta EE specification, add the following to your project pom.
  • <groupId>org.jboss.spec</groupId>
  • <artifactId>jboss-jakartaee-8.0</artifactId>
  • <version>1.0.0.Final</version>

Jakarta EE Web Profile APIs

If you are developing web applications and depend only on technologies that comprise the Jakarta EE Web Profile specification, you can opt to use the web profile pom.
  • <groupId>org.jboss.spec</groupId>
  • <artifactId>jboss-jakartaee-web-8.0</artifactId>
  • <version>1.0.0.Final</version>

Jakarta EE API UberJar

Else, if you prefer a jar containing the Jakarta EE API classes, that is also made available per a previous feature request.
  • <groupId>org.jboss.spec</groupId>
  • <artifactId>jboss-jakartaee-8.0-all</artifactId>
  • <version>1.0.0.Final</version>

These examples show the group:artifactId for use with Jakarta EE 8. Releases are available for Java EE 6, 7 and 8 also.

Versions

Version
1.0.0.Final