JBoss Java EE 6 Web Profile APIs


License

License

Categories

Categories

JBoss Container Application Servers
GroupId

GroupId

org.jboss.spec
ArtifactId

ArtifactId

jboss-javaee-web-6.0
Last Version

Last Version

3.0.3.Final
Release Date

Release Date

Type

Type

pom
Description

Description

JBoss Java EE 6 Web Profile APIs
JBoss Java EE 6 Web Profile APIs
Project Organization

Project Organization

JBoss by Red Hat
Source Code Management

Source Code Management

https://github.com/jboss/jboss-javaee-specs

Download jboss-javaee-web-6.0

How to add to project

<!-- https://jarcasting.com/artifacts/org.jboss.spec/jboss-javaee-web-6.0/ -->
<dependency>
    <groupId>org.jboss.spec</groupId>
    <artifactId>jboss-javaee-web-6.0</artifactId>
    <version>3.0.3.Final</version>
    <type>pom</type>
</dependency>
// https://jarcasting.com/artifacts/org.jboss.spec/jboss-javaee-web-6.0/
implementation 'org.jboss.spec:jboss-javaee-web-6.0:3.0.3.Final'
// https://jarcasting.com/artifacts/org.jboss.spec/jboss-javaee-web-6.0/
implementation ("org.jboss.spec:jboss-javaee-web-6.0:3.0.3.Final")
'org.jboss.spec:jboss-javaee-web-6.0:pom:3.0.3.Final'
<dependency org="org.jboss.spec" name="jboss-javaee-web-6.0" rev="3.0.3.Final">
  <artifact name="jboss-javaee-web-6.0" type="pom" />
</dependency>
@Grapes(
@Grab(group='org.jboss.spec', module='jboss-javaee-web-6.0', version='3.0.3.Final')
)
libraryDependencies += "org.jboss.spec" % "jboss-javaee-web-6.0" % "3.0.3.Final"
[org.jboss.spec/jboss-javaee-web-6.0 "3.0.3.Final"]

Dependencies

compile (17)

Group / Artifact Type Version
javax.enterprise : cdi-api jar
javax.inject : javax.inject jar
javax.validation : validation-api jar
org.hibernate.javax.persistence : hibernate-jpa-2.0-api jar
org.jboss.spec.javax.annotation : jboss-annotations-api_1.1_spec jar
org.jboss.spec.javax.ejb : jboss-ejb-api_3.1_spec jar
org.jboss.spec.javax.el : jboss-el-api_2.2_spec jar
org.jboss.spec.javax.faces : jboss-jsf-api_2.1_spec jar
org.jboss.spec.javax.interceptor : jboss-interceptors-api_1.1_spec jar
org.jboss.spec.javax.resource : jboss-connector-api_1.6_spec jar
org.jboss.spec.javax.security.auth.message : jboss-jaspi-api_1.0_spec jar
org.jboss.spec.javax.servlet : jboss-servlet-api_3.0_spec jar
org.jboss.spec.javax.servlet.jsp : jboss-jsp-api_2.2_spec jar
org.jboss.spec.javax.servlet.jstl : jboss-jstl-api_1.2_spec jar
org.jboss.spec.javax.transaction : jboss-transaction-api_1.1_spec jar
org.jboss.spec.javax.ws.rs : jboss-jaxrs-api_1.1_spec jar
org.jboss.spec.javax.xml.bind : jboss-jaxb-api_2.2_spec jar

Project Modules

There are no modules declared in this project.

JBoss JavaEE Specs API

This project provides dependency management for a complete set of required APIs as defined by the Java EE Platform Specifications.

This project, which originated from the legacy jbossas/projects/specs SVN repository, was enhanced to produce an aggregation of the APIs required by the Java EE Platform Specification. Further changes included migration to a github/jboss repository. The goals initiating this move and restructure were:

  • Maintain a single repository containing the required APIs as defined by the EE Platform Specification
  • Having a consistent structure for all the EE APIs make it easier to access, maintain, and consume.
  • Individual release cycle per technology component
  • Restructuring the project so each API set can be released individually provides greater flexibility and control to the project owners without waiting for the aggregate to be released and integrated. These API releases can be consumed by your project as a single dependency or as a fully defined set of required APIs for the profile.
  • Define a naming scheme to associate the Specification version to the APIs contained in the JAR and distinguish between that and the release version of the artifact
  • The naming scheme adopted is as follows:
    • groupId: org.jboss.spec + the package name
    • artifactId: Technology-api_SpecVersion_spec
    • version: release version of the artifact
  • Promote adoption of these spec-versioned APIs in all JBoss projects
  • The APIs released from the org.jboss.specs project are certified for compliance to their respective specification.

Java EE Full Profile APIs

If you require the full set of required technology APIs defined by the Java EE specification, add the following to your project pom.
  • <groupId>org.jboss.spec</groupId>
  • <artifactId>jboss-javaee-8.0</artifactId>
  • <version>1.0.1.Final</version>

Java EE Web Profile APIs

If you are developing web applications and depend only on technologies that comprise the Java EE Web Profile specification, you can opt to use the web profile pom.
  • <groupId>org.jboss.spec</groupId>
  • <artifactId>jboss-javaee-web-8.0</artifactId>
  • <version>1.0.1.Final</version>

Java EE API UberJar

Else, if you prefer a jar containing the EE API classes, that is also made available per a previous feature request.
  • <groupId>org.jboss.spec</groupId>
  • <artifactId>jboss-javaee-8.0-all</artifactId>
  • <version>1.0.1.Final</version>

These examples show the group:artifactId for use with Java EE 8. Releases are available for Java EE 6 and 7 also.

Versions

Version
3.0.3.Final
3.0.2.Final
3.0.1.Final
3.0.0.Final
3.0.0.Beta1
2.1.0.Beta1
2.0.0.Final
2.0.0.CR1